Warum braucht 'Pip' "setuptools> = 0.8", obwohl ich 2.1 installiert habe?

Wenn ich bestimmte Befehle mit pip versuche, bekomme ich eine Fehlermeldung, dass pip

 “requires setuptools >= 0.8 for dist-info” 

Obwohl ich habe, nach yolk -l (sowie pip list ), eine viel höhere Version von setuptools installiert:

 pip - 1.5 - active ... setuptools - 2.1 - active 

Warum fragt pip nach einer Version von setuptools > = 0.8? Ist nicht 2.1> 0.8; Oder ist meine Installation nicht in der Tat auf die Version, die yolk berichtet? Gibt es etwas, das ich tun muss, um sicherzustellen, dass ich eigentlich "setuptools" = 0.8 habe?

One Solution collect form web for “Warum braucht 'Pip' "setuptools> = 0.8", obwohl ich 2.1 installiert habe?”

Sie können mehr als ein Setup installieren. Wenn es einen Link zu niedrigeren Version Pip gibt, würde man das sehen. Zum Beispiel python erscheint in der Regel auf beiden usr / bin und usr / local / bin, hatte ich eine ähnliche Version Problem und umbenannt die in usr / local / bin. Wenn dies der Fall ist, sollten Sie herausfinden, welche Versionen installiert sind und umbenennen / entfernen Sie die untere Version.

  • Vergleichen Sie Versionszeichenfolgen in Python
  • So verwenden Sie mehrere Versionen von Python ohne Deinstallation
  • Was ist besser, um Windows-Version in Python zu bekommen?
  • Python-Version aus Quellcode (oder Heroku) herausfinden
  • Speichern Sie die Version des Feldes in einem Django-Modell
  • Wie man die Standard-Python-Version auf Windows XP ändern kann
  • Wie importiere ich. .pyc-Datei aus einer anderen Version von Python?
  • Python- und OpenSSL-Versionsreferenz auf OS X
  • Holen Sie sich Python Tornado Version?
  • Python-IDLE: Python-Version ändern
  • Installiere bestimmte Version mit easy_install
  • Python ist die beste Programmiersprache der Welt.