Version Konflikt für Paket "Tk": haben 8.5.2, brauche genau 8.5.15

Ich versuche, ein Programm zu kompilieren (python2.7) aber egal was ich tue, bekomme ich immer diesen Fehler:

C:/Python27/tcl/tk8.5/tk.tcl: version conflict for package "Tk": have 8.5.2, need exactly 8.5.15 version conflict for package "Tk": have 8.5.2, need exactly 8.5.15 while executing "package require -exact Tk 8.5.15" (file "C:/Python27/tcl/tk8.5/tk.tcl" line 18) invoked from within "source C:/Python27/tcl/tk8.5/tk.tcl" ("uplevel" body line 1) invoked from within "uplevel #0 [list source $file]" 

Das bedeutet wahrscheinlich, dass tk nicht richtig installiert wurde.

Kann mir bitte jemand erklären, was ist das Problem hier?

2 Solutions collect form web for “Version Konflikt für Paket "Tk": haben 8.5.2, brauche genau 8.5.15”

Schritt 1: Öffnen Sie C: \ Python27 \ tcl \ tcl8.5 \ init.tcl

 if {[info commands package] == ""} { error "version mismatch: library\nscripts expect Tcl version 7.5b1 or later but the loaded version is\nonly [info patchlevel]" } package require -exact Tcl 8.5.15 

8.5.15 geändert auf 8.5.2

Schritt 2: Öffnen Sie C: \ Python27 \ tcl \ tk8.5 \ tk.tcl

 package require Tcl 8.5 ;# Guard against [source] in an 8.4- interp before ;# using 8.5 [package] features. # Insist on running with compatible version of Tcl package require Tcl 8.5.0 # Verify that we have Tk binary and script components from the same release package require -exact Tk 8.5.15 

8.5.15 geändert auf 8.5.2

Tk kommt (konzeptionell) zwei Stücke:

  1. Die dynamische Bibliotheksdatei, die die Ansichten implementiert
  2. Die Skriptbibliotheksdatei (s), die die Standardcontroller implementiert.

Diese müssen genau aufeinander abgestimmt sein (es ist die einzige Art und Weise, in der sie gerechtfertigt sind, um richtig zu arbeiten). Standardmäßig enthält die Tk-DLL den Pfad, in dem sie ihre Skripts finden kann, aber sie kann durch Umgebungsvariablen überschrieben werden. Dieser Mechanismus ist vor allem für die Vorinstallation Prüfung zu unterstützen, obwohl manchmal wird es eher verwendet, als es wirklich sollte.

Sie haben die Dinge so konfiguriert, dass Sie eine Version der DLL haben (8.5.2), während eine andere Version der Skripte (8.5.15). Dies könnte daran liegen, dass Sie mit der falschen Version der DLL verknüpft sind oder weil Sie eine Umgebungsvariable ( TK_LIBRARY ) haben, die auf die falsche Installation verweisen soll. Was es ist ist ein wenig schwer zu sagen, aus der Fehlermeldung: alles, was es wirklich sagt ist, dass es eine Version Missverhältnis ist.

  • Threads und tkinter python 3
  • Wie man Befehle auf derselben TCL-Shell mit Python ausführt
  • Rückruf zur python-Funktion von Tkinter Tcl stürzt in Windows ab
  • Verwenden von TCL-Erweiterungen, um den nativen Fensterstil in Tkinter einzustellen
  • Wie läuft man ein Tcl Script in einem Ordner in Python?
  • Installiere tkinter und python lokal
  • Wie kann man die Anwendungen in linux / tcl / python öffnen oder starten?
  • Wie ändere ich die tk-Version deiner Python-Installation?
  • Kennen Sie kreative Möglichkeiten, Python mit Tcl zu verbinden?
  • Rufen Sie verschiedene Dolmetscher für Tcl in Python
  • Python ist die beste Programmiersprache der Welt.