Tag: virtualenv

Wie installiere ich welche Programme "sudo" in virtualenv?

Ich versuche, Kivy zu installieren, in den docs heißt es: $ sudo apt-get install python-setuptools python-pygame python-opengl \ python-gst0.10 python-enchant gstreamer0.10-plugins-good cython python-dev \ build-essential libgl1-mesa-dev libgles2-mesa-dev $ sudo easy_install kivy Aber ich möchte nicht sudo Ich mag meine Projekte in virtualenv organisiert halten, also wie installiere die Anforderungen ohne sudo . apt-get install wird […]

Wie verwende ich Conda im Homebrew Python System?

Ich bin mit Homebrew als mein Paket General Manager, und bin mit seinem Python und Pip für Software-Entwicklung, zusammen mit virtualenvs. Aus verschiedenen Gründen möchte ich mit dieser Struktur fortsetzen, aber ich brauche eine Software, die ( anscheinend ) einfacher mit Conda zu installieren ist. Kann ich weiterhin Homebrew + pip + virtualev verwenden und […]

Cxfreeze fehlt distutils module inside virtualenv

Beim Ausführen einer cxfreeze-Binärdatei aus einem python3.2-Projekt bekomme ich folgende Laufzeitfehler: /project/dist/project/distutils/__init__.py:13: UserWarning: The virtualenv distutils package at %s appears to be in the same location as the system distutils? Traceback (most recent call last): File "/home/chrish/.virtualenvs/project/lib/python3.2/distutils/__init__.py", line 19, in <module> import dist ImportError: No module named dist Entsprechend gibt es mehrere distutils Einträge im […]

Python installieren xmlrpclib

Ich bin in einem virtualenv und versuche, ein Skript auszuführen, bekomme ich folgendes: Traceback (most recent call last): File "blah.py", line 15, in <module> from xmlrpc import server ImportError: No module named xmlrpc Ok, so dass scheint, dass ich xmlrpc brauche, was ich annehme, ich brauche xmlrpclib Also versuche ich das: (env) ❯❯❯ pip2.7 install […]

Probleme mit getsitepackages unter einem virtualenv

Ich wollte herausfinden, welcher Python-Interpreter unter meinem virtuellen env lief, also bin ich gerade in den virtualenv gekommen und habe ausgegeben. Das ist was herauskam (test)~/Documents/Development/test$ python Python 2.7.9 (default, Apr 7 2015, 07:58:25) [GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.57)] on darwin Type "help", "copyright", "credits" or "license" for more information. >>> import site […]

Argumentfehler bei der Installation von virtualenvwrapper-powershell

Versuche, virtualenvwrapper-powershell zu installieren, aber folgende Fehler zu haben: chown() missing 1 required positional argument: 'numeric_owner' Ich habe es nach dem Lesen dieses Artikels: Https://bitbucket.org/guillermooo/virtualenvwrapper-powershell/issues/5/cant-install-package-with-python3-and-pip (Eigentlich hatte ich ein Problem in ihm beschrieben) Guy namens Alexander Zonov vorgeschlagen: Wir haben schon eine Lösung. Download virtualenvwrapper-powershell Finde Datei setup.py Änderungsproblem String zu diesem ein TOKEN_READ = […]

Virtualenv nicht gefundenes aktualisiertes Modul

Ich laufe python-2.7 mit virtualenv auf einem Unix-Server, auf den ich keinen Root-Zugriff habe. Ich aktualisierte das Modul Tornado mit Pip installieren Tornado – Upgrade, weil die Installation von ipython erforderlich Tornado> = 3.1.0 aber nur Version 2.4 wurde standardmäßig auf dem Server installiert. Allerdings, wenn ich versuche, ipython zu öffnen, beklagt es immer noch, […]

Verwenden Sie Sublime mit virtualenv

Also lese ich durch die Verwendung von virtualenv mit erhabenem Text 2 , aber sehen, wie die akzeptierte Antwort eindeutig falsch ist, bin ich immer noch sehr verwirrt. Ich versuche, meine chorus.py Datei aus dem Sublime chorus.py . Ich habe mein Build-System verändert, um so auszusehen: "build_systems": [ { "name": "Scraper", "cmd" : ["/Users/thumbtackthief/.virtualenvs/chorus", "$file"] […]

Virtualenv: konnte nicht '/lib/python2.7' erstellen: Permission denied

Was könnte hier falsch sein? user@linux> virtualenv foobar …. error: could not create '/lib/python2.7': Permission denied —————————————- …Installing Setuptools…done. Traceback (most recent call last): File "/usr/bin/virtualenv", line 9, in <module> load_entry_point('virtualenv==1.10.1', 'console_scripts', 'virtualenv')() File "/usr/lib/python2.7/site-packages/virtualenv.py", line 821, in main symlink=options.symlink) File "/usr/lib/python2.7/site-packages/virtualenv.py", line 961, in create_environment install_sdist('Setuptools', 'setuptools-*.tar.gz', py_executable, search_dirs) File "/usr/lib/python2.7/site-packages/virtualenv.py", line 932, in […]

Pyvenv kann keine virtuelle Umgebung erstellen

Normalerweise verwende ich virtualenv für python2.x. Nach einigen bitteren Erfahrungen mit unicode Encoding / Decoding-Clash habe ich beschlossen, auf 3.x zu aktualisieren, aber ich kann kein virtualenv mit pyvenv erstellen. $ pyvenv-3.4 env Error: Command '['/home/user/delete_this/env/bin/python3.4', '-Im', 'ensurepip', '–upgrade', '–default-pip']' returned non-zero exit status 1 Auch wäre ich dankbar, wenn jemand auf eine gute virtuelle […]

Python ist die beste Programmiersprache der Welt.