Installieren von Python 2.5.2 auf OS X 10.6

Ich installiere Python 2.5.2 auf meinem Mac (OSX 10.6).

Ich habe die Quelle heruntergeladen, lief ./configure , und dann lief. Ich habe diesen Fehler erhalten:

 gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I. -IInclude -I./Include -DPy_BUILD_CORE -o Modules/python.o ./Modules/python.c cc1: error: unrecognized command line option "-Wno-long-double" make: *** [Modules/python.o] Error 1 

Was ist das Problem?

One Solution collect form web for “Installieren von Python 2.5.2 auf OS X 10.6”

Siehe meine Antwort hier . Während Sie es von Grund auf mit den vorgeschlagenen Patches bauen können, kann es viel einfacher sein, einfach einen vorinstallierten Installateur von python.org herunterzuladen, wie es dort vorgeschlagen wird.

  • Install psycopg2 auf mac osx 10.9.5 [pg_config] [pip]
  • Workaround OSError mit os.listdir
  • Installieren von Pythonpaketen mit mehreren Versionen auf OSX
  • Installieren von Python 2.5 auf Mac 10.6, für GAE / Django-nonrel (und ich bin ein neuer Mac User)
  • Tkinter mac, minimieren Bildschirm
  • Wie kann ich python von OSX Leopard deinstallieren, damit ich die MacPorts Version verwenden kann?
  • Psycopg2 auf OSX: muss ich auch PostgreSQL installieren?
  • PyCrypto und GMP-Bibliothek nicht gefunden Fehler [Mac OS 10.6.3]
  • Rekord-Ausgangssound in Python
  • Python 3.3 und Installation von PyOpenSSL auf einem Mac
  • Wie kann ich python 2.6 meine Vorgabe in Mac OS X Lion machen?
  • Python ist die beste Programmiersprache der Welt.