Installiere bestimmte Version mit easy_install

Ich versuche, lxml zu installieren. Ich habe einen Blick auf die Website und Version 2.2.8 sah mir vernünftig aus, aber als ich easy_install lxml , installierte es Version 2.3.beta1, was nicht wirklich das ist, was ich will, vermute ich.

Was ist der beste Weg, um dies zu beheben und wie kann ich force_install erzwingen, eine bestimmte Version zu installieren?

(Mac os x 10,6)

3 Solutions collect form web for “Installiere bestimmte Version mit easy_install”

Ich glaube, die Art, eine Version anzugeben, wäre so:

 easy_install lxml==2.2.8 

Ich (und die meisten anderen Python-Benutzer, die ich vermute) gestoppt mit easy_install und begann mit pip einiger Zeit, so eine Lösung in diesen Bedingungen ist:

 easy_install pip pip install lxml==2.2.8 

( pip hat mehrere Vorteile, einschließlich eines uninstall )

Aus der easy_install Dokumentation :

easy_install PackageName==1.2.3

Du solltest so etwas machen:

 easy_install "lxml==2.2.8" 
  • Wie füge ich Python 3.3 zu Powershell hinzu?
  • Holen Sie sich Python Tornado Version?
  • Python-IDLE: Python-Version ändern
  • Wie überprüfe ich, welche Version von Python mein Skript ausführt?
  • Wie überprüfe ich, welche Version von Python mein Skript ausführt?
  • Python-qgis Versionsinformationen
  • Wie sage ich einem Python-Skript, um eine bestimmte Version zu verwenden
  • RuntimeWarning: Compiletime Version 2.6 des Moduls 'lxml.etree' entspricht nicht der Laufzeitversion 2.7
  • Buildout - mit verschiedenen python version
  • Scikit-Lernversion Mehrdeutigkeit
  • Kann keine Flasche-Mail installieren
  • Python ist die beste Programmiersprache der Welt.