Fehler beim Installieren von pyobjc auf Anaconda python auf OSX 10.10.2

Ich habe Python 3.3.5 :: Anaconda 2.1.0 (x86_64) unter Mac OS X 10.10.2 mit XCode 6.2 (6C131e) und Pip 6.0.8

Ich versuche, PyObjC nach dem Guide zu installieren. Aber wenn ich es tue

pip install -U pyobjc 

Ich bekomme folgende Fehlermeldung:

 $ pip install -U pyobjc Requirement already up-to-date: pyobjc in ./anaconda/lib/python2.7/site-packages/pyobjc-3.1-py2.7.egg Downloading/unpacking py2app>=0.9 (from pyobjc) Downloading py2app-0.9.tar.gz (1.7MB): 1.7MB downloaded Running setup.py (path:/private/var/folders/hc/fbm2svb951n5wr35bnw_qyqr0000gn/T/pip_build_user/py2app/setup.py) egg_info for package py2app warning: no directories found matching 'doc/_static' warning: no directories found matching 'doc/_templates' warning: no previously-included files matching '.DS_Store' found anywhere in distribution warning: no previously-included files matching '*.pyc' found anywhere in distribution warning: no previously-included files matching '*.pyo' found anywhere in distribution warning: no previously-included files matching '*.so' found anywhere in distribution warning: no previously-included files matching '*.dSYM' found anywhere in distribution warning: no previously-included files matching '*.dSYM/*' found anywhere in distribution warning: no previously-included files matching '*__pycache__*' found anywhere in distribution no previously-included directories found matching 'examples/*/build' no previously-included directories found matching 'examples/*/dist' no previously-included directories found matching 'examples/*/*/build' no previously-included directories found matching 'examples/*/*/dist' no previously-included directories found matching 'examples/*/*/*/build' no previously-included directories found matching 'examples/*/*/*/dist' Requirement already up-to-date: pyobjc-core==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_core-3.1-py2.7-macosx-10.5-x86_64.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-AddressBook==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_AddressBook-3.1-py2.7-macosx-10.5-x86_64.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-AppleScriptKit==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_AppleScriptKit-3.1-py2.7.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-Automator==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_Automator-3.1-py2.7.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-CFNetwork==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_CFNetwork-3.1-py2.7-macosx-10.5-x86_64.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-Cocoa==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_Cocoa-3.1-py2.7-macosx-10.5-x86_64.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-CoreData==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_CoreData-3.1-py2.7.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-CoreText==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_CoreText-3.1-py2.7-macosx-10.5-x86_64.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-DiskArbitration==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_DiskArbitration-3.1-py2.7.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-ExceptionHandling==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_ExceptionHandling-3.1-py2.7.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-InstallerPlugins==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_InstallerPlugins-3.1-py2.7.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-LatentSemanticMapping==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_LatentSemanticMapping-3.1-py2.7.egg (from pyobjc) Requirement already up-to-date: pyobjc-framework-LaunchServices==3.1 in ./anaconda/lib/python2.7/site-packages/pyobjc_framework_LaunchServices-3.1-py2.7.egg (from pyobjc) Downloading/unpacking pyobjc-framework-Message==3.1 (from pyobjc) Could not find a version that satisfies the requirement pyobjc-framework-Message==3.1 (from pyobjc) (from versions: 2.2, 2.2b1, 2.2b2, 2.2b4, 2.3, 2.4, 2.5.1, 3.0.1, 3.0.3, 3.0.4) Cleaning up... No distributions matching the version for pyobjc-framework-Message==3.1 (from pyobjc) 

Googeln die Fehlermeldung, fand ich diese , wo es als gelöscht markiert ist, so bin ich nicht sicher, wie es weiter geht

One Solution collect form web for “Fehler beim Installieren von pyobjc auf Anaconda python auf OSX 10.10.2”

Das Problem mit der Installation von PyObjC 3.1 mit Anaconda kann durch die Einstellung von "MACOSX_DEPLOYMENT_TARGET = 10.9" vor dem Ausführen von Pip bearbeitet werden, als Beispiel:

 $ MACOSX_DEPLOYMENT_TARGET=10.9 pip install -U pyobjc-core $ MACOSX_DEPLOYMENT_TARGET=10.9 pip install -U pyobjc 

Es wird eine richtige Korrektur in pyobjc 3.2 geben, aber ich weiß noch nicht, wann das freigegeben wird.

  • Ziehen Sie das Timeout mit dem Google-api-python-Client ab
  • Warum wählt matplotlib die falsche Reichweite in y mit Log-Skala?
  • Implementierung von QProgressBar gegen eine Klasse
  • Ajax postdaten in der flaschenansicht
  • Wie integriere ich SimpleGUI mit Python 2.7 und 3.0 Shell
  • Segfault wenn import_array nicht in der gleichen Übersetzungseinheit
  • Warum "tf.Variable ([3], tf.float32)" Arbeit im Tensorfluss?
  • Piping Binärdaten zwischen Python und C ++
  • Pysvn bekomme neueste Revisionsnummer für spezifisches Verzeichnis (nicht Kopf)
  • So finden Sie einen offenen Leserahmen in Python
  • Wie bekomme ich Element aus XML-Datei mit Attribut mit einem bestimmten Wert
  • Python ist die beste Programmiersprache der Welt.