Das Importieren von PIL, genauer gesagt von PIL, funktioniert nicht

Hier ist eine Beschreibung dessen, was ich gemacht habe.

Ich versuche, ein Programm mit PIL zu schreiben, aber beim Versuch, es zu importieren (wie unten gezeigt), erscheint ein Fehler (siehe auch unten).

from PIL import Image 

Hier ist der Fehler.

 Traceback (most recent call last): File "C:/Users/user/Desktop/Wook/Test Bench.py", line 1, in <module> from PIL import Image File "C:\Python\lib\site-packages\PIL\Image.py", line 56, in <module> from . import _imaging as core ImportError: DLL load failed: The specified procedure could not be found. 

Ich habe versucht, einfach zu import Image :

Aber es zeigt auch einen Fehler an:

Hier ist der Fehler in der zweiten Situation.

 Traceback (most recent call last): File "C:/Users/user/Desktop/Wook/Test Bench.py", line 1, in <module> import Image ModuleNotFoundError: No module named 'Image' 

Hier ist eine sehr kurze Liste von dem, was ich versucht habe, das Problem zu lösen:

  • PIL installieren ( konnte keine Version finden, die die Anforderung erfüllt PIL (aus Versionen:) Keine übereinstimmende Verteilung für PIL gefunden ), genügt es zu sagen, es hat nicht funktioniert;
  • Deinstallieren von PIL, aber ich kann nicht deinstallieren, was ich nicht installiert habe ( Kann nicht die Anforderung PIL, nicht installiert );
  • Ich habe versucht, Kissen zu installieren, aber es ist bereits installiert;
  • Ich habe versucht, Kissen zu deinstallieren (um es dann wieder zu installieren und zu sehen, ob es funktionieren würde), hat es nichts gelöst.

Das ist alles, was ich versucht habe. Wenn jemand mir helfen kann, wäre es zutiefst geschätzt, und wenn irgendwelche weiteren Informationen zur Verfügung gestellt werden müssen, kann es und wird bereitgestellt werden.

One Solution collect form web for “Das Importieren von PIL, genauer gesagt von PIL, funktioniert nicht”

Es gibt ein Python-Problem, das bedeutet, dass Räder, die gegen Python 3.6.1 gebaut wurden, wie Pillow 4.1.0, nicht auf Python 3.6.0 arbeiten.

Das Update soll auf Python 3.6.1 aktualisieren oder Pillow 4.0.0 installieren (das gegen Python 3.6.0 gebaut wurde).

Weitere Informationen finden Sie unter: https://github.com/python-pillow/Pillow/issues/2479 https://mail.python.org/pipermail/python-dev/2017-March/147707.html https: // Bugs .python.org / issue29943


Aktualisieren:

Dies hat eine Reihe von Python-Bibliotheken beeinflusst.

Allerdings gibt es die neue Pillow 4.1.1 Release funktioniert um diese, so können Sie jetzt auf Pillow 4.1.1 aktualisieren und verwenden Sie es mit Python 3.6.0 und 3.6.1.

  • Trennen Sie das Bild des Textes in Komponentenzeichenbilder
  • Hinzufügen eines transparenten Kreises zu einem Bild auf Python mit PIL
  • Umwandlung von PIL-Bild in GTK Pixbuf
  • PIL-Fehler: Das Modul _imaging C ist nicht installiert
  • Liste der Pixelwerte von PIL erhalten
  • Bild mit Kissen importieren: Kein Modul namens 'PIL'
  • Ist es möglich, encodeb64 aus Image-Objekt zu erstellen?
  • Ernte nicht symmetrischen Bereich eines Bildes mit Python / PIL
  • Fraktale Bildskalierung mit Python
  • Bildbibliothek für Python 3
  • Konvertieren Sie das Bild in eine bestimmte Palette mit PIL ohne Dithering
  • Python ist die beste Programmiersprache der Welt.